Translate

Showing posts with label Computer. Show all posts
Showing posts with label Computer. Show all posts

Thursday, March 14, 2013

10 Steps To Securing Your Computer's Firewall


After installing an expensive alarm system in his apartment and then getting robbed, Jerry Seinfeld learned a valuable lesson: no matter how good the security system, if it isn't used correctly, it is completely ineffective. That lesson holds just as true when it comes to everyday computer users and their firewalls.

Most computers now come with a firewall built in, but despite this, the number of computers that are infected with viruses, worms and other types of malware grows by the day. One of the biggest reasons why firewalls are not doing their job, is because many of us have never taken the time to tweak our firewall to make it effective. This 10 step list will help introduce individuals and small business owners alike to some very simple ways that they can tweak, supplement, and support their firewall in order to keep their computer and private information as secure as possible.

1. INSTALL WINDOWS XP, SERVICE PACK 2, ONTO YOUR WINDOWS OPERATING SYSTEM
Before you can start supporting or tweaking your firewall, it is important to make sure you actually have one installed. Surprisingly, a large number of individuals who believe they are already protected, have not even taken the most basic step of installing a free firewall.

If you are using Microsoft's Windows XP and just assumed that you were protected by a built-in firewall, you may be wrong. In fact, the standard version of Microsoft's Windows XP is notoriously vulnerable to worms and viruses precisely because it has no substantial built-in firewall. In response to the criticisms, Microsoft created an all-in-one patch (or downloadable add-on) to Windows XP called SP2. By downloading and installing SP2 onto your computer, you will automatically be equipped with Windows Security Center, Windows Firewall, a Pop-up blocker for Internet Explorer, an Email virus scanner for Outlook Express, and a Wireless Network Security system.[http://www.microsoft.com/windowsxp/sp2/default.mspx]

Given the standard version of Windows XP's notorious weaknesses against worms and viruses, it is a necessary first step for all individual and small business users who use Windows XP to download the all-in-one patch. Make sure, however, to download the patch directly from Microsoft, as clever spammers often offer a version on their own sites which are full of hidden viruses. [http://www.microsoft.com/windowsxp/sp2/default.mspx].

For those individuals that haven't been using any sort of firewall whatsoever, having SP2 in place is a big step up. Unfortunately, however, the Windows Firewall will only block attacks that come from the outside, it just presumes that anything you send out is safe. But, if you have been connecting your computer to the internet without a firewall in the past, that assumption is probably wrong. Your computers may already be infected and you simply have no idea. To deal with this problem you will need to install a 'bidirectional' third-party firewall. For individuals, there are some good free ones available, including Zone Labs' ZoneAlarm. If ZoneAlarm does not fit your needs, there are dozens of other options. Check out PCWorld's firewall review for a few more ideas. [http://www.zonelabs.com/store/content/company/products/znalm/freeDownload.jsp][http://www.pcworld.com/article/id,115939-page,1/article.html?findid=42886#]

Now that we have made sure that you actually have a firewall in place, it is time to start optimizing it.

2. ENABLE AUTO UPDATES FOR THE FIREWALL.
New viruses, worms and other forms of malware are created daily, so it is important that once a firewall is installed in your personal computer or across your company's computers, you develop a plan to regularly check for and install new patches for your firewall. While normally it is a terrible idea to let your computer download anything without your approval, when it comes to fighting viruses, there is a whole new set of rules. Because every small business is strapped for time, the only reliable means of ensuring that your business's firewalls remain up to date is to setup auto-updates. Once automatic updates are set up, your firewall will upload the newest patches each time you have them scheduled or each time you turn off your computer. These updates will enable to firewall to protect your computer against any new viruses, worms, Trojan horses or bugs that have been created since the program was last updated.

If you are using the default Windows XP firewall that you downloaded with the SP2 patch, then you should simply enable Windows Automatic Updates. This is a program for Windows that will actually check to see what patches you need, and then suggest that you download them. Once you are current, the program will frequently check for new updates and when they are created, it will wait for a time when your computer is idle, so as not to interrupt your work, and automatically download the new patch. The setup for Automatic Updates is a simple step-by-step process that will not take more than 15 minutes to complete, even fore the most technically disinclined. [http://www.microsoft.com/athome/security/update/msupdate_keep_current.mspx]

If you decided to opt for greater protection and downloaded or purchased a 'bidirectional' firewall you can still setup automatic updates, and typically the process is very straightforward. If you selected the free version of ZoneAlarm, the setup instructions are here, otherwise you will simply need to check the manufacturer’s website for instructions on how to setup auto updates for your firewall.
[http://www.zonelabs.com/store/content/support/zasc/index.jsp?dc=12bms&ctry=US&lang=en&lid=zasupp_c]

3. TWEAKING THE SETTINGS TO YOUR USAGE
Firewall settings are designed with the median user in mind. The problem is, none of us is that mythical 'median' user, so almost everyone will benefit from tweaking the settings on their firewall.

One of the most common tweaks is the timing of automatic updates. You enabled automatic updates to take place because they will keep your firewall updated all the time. But that can only happen if the 'automatic update' actually happens. For most firewalls the automatic update is timed to start each night at 3 a.m. If you typically have your computer off and disconnected from the internet at that time, however, your firewall will never update. So, make sure to schedule your updates for a time when the computer is going to be on and connected, but not in heavy use. If you cannot come up with a time that works for your home or business, just select an option that the computer notify you when an update is ready, and then you can decide pick a convenient time that day.

At work, most of us are focused on getting the job done in the quickest way possible. So if your employees are having trouble with a pop-up blocker (e.g. it is blocking pop-ups they need to sign in or fill out a form) often they will just disable the pop-up blocker rather than spending the time to whitelist that site. Very soon, you will find that all the computers in your company now have disabled pop-up blockers, and as a result your firewall has to filter a lot more bad content, and ultimately your computer is less secure. Rather than have that happen, make sure to tweak your firewall to allow exceptions, by listing all the trusted sites that your employees will need to frequently visit throughout their workday. So for instance, if your employees constantly need to sign in to the company email provider, which uses a pop-up, make sure that that site is listed in your 'trusted sites' list so that pop-ups can appear. Just adding the five or ten sites that your employees visit most frequently to the exceptions list, will stop them from disabling that pop-up blocker, and keep your whole network safer.
[http://www.microsoft.com/windowsxp/using/security/internet/sp2_wfexceptions.mspx]

For a hacker to be effective, he or she needs a way to get information on and off your computer without you knowing. One of the most common ways they do this is by hiding their malware inside of a legitimate program, and then directing that legitimate program to establish a connection between your computer and the internet. Untweaked firewalls that are left to their default settings can often do little to prevent this, as the firewall does not know which programs need to send and receive messages from the internet and which do not. But, by tweaking the settings of your firewall, you can restrict those of your programs that do not need to send and receive information from the internet from doing so. One of the most common steps is to restrict your printer from having access to anything beyond the local network level. That way, a virus will not be able to embed itself into your printer software and send and receive information through that connection. For those programs that do require internet access, you should consider whether they need to both send and receive information, or whether they might simply send information. If that is the case, you can toggle your settings so that that program is restricted to sending outgoing information, but cannot receive incoming information. While this offers less protection than a total block, it is certainly better than the default firewall setting.

4. KEEPING SETTINGS CONSISTENT ACROSS NETWORKS
In most companies and homes, individual users access the internet and use their computers in wildly different ways. Because of these different uses, many individuals and small companies decide to setup the individual firewalls within a network differently according to the usage habits of that individual. For example, if a person accesses a certain site more than the other users, he might authorize that site to show pop-ups by adding it to his ‘trusted site’ list. And even more commonly, an individual employee might decide to toggle their firewall settings to permit Instant Messenger to function without hindrance.

While these sorts of individualized tweaks can seem harmless, in fact they create different attack surfaces for each computer throughout the network, so that when a worm or other malicious program eventually succeeds in breaching the firewall, it is far more difficult to tell where the firewall vulnerability is located, and thus what change needs to be made to close up the weakness. This same reasoning also requires that the firewall administrator not permit different firewall settings for each connection, or profile, on the computer. Just as individualized firewall settings on different computers make it difficult to identify where the firewall weakness is, having different settings for different users within the same computer make the task of identification nearly impossible.

5. ADD MULTIPLE LAYERS TO YOUR PC AND SECURITY SYSTEM.
An easy way to think about a firewall, is that it is a program that creates a sort of shell around your computer that lets certain types of authorized information pass through it, while identifying and blocking out other types of code or information that it recognizes as bad. But for all their advancements, firewalls are and will always be defensive in nature. That means, that a firewall can only block malware that humans have coded it to recognize as bad, and that code can only be created for viruses that already exist and have already infected some computers.

Because of the inherent defensive nature of firewalls, they are always fighting an uphill battle against hackers who are creating new sorts of malware. Thus, to help put a firewall on equal footing, it must always be supplemented with an aggressive anti-virus program. Unlike a firewall which tries to form a shell around your computer, an anti-virus program scans information that has gotten through the firewall and quarantines then eliminates the malware that it finds. That way, even if a new virus is quick enough to sneak past your firewall, it will eventually be rooted out by your anti-virus software, once your software is updated to recognize the new virus.

In addition to an anti-virus program, you should also add a pop-up blocker and spam-blocking software to your company's computers. While these two firewall supplements will not directly fight against attacks by viruses, worms, and trojan horses, they will limit the number of these types of malware that your computer faces, and thus help make your firewall more effective overall.

Because many viruses are designed specifically for Internet Explorer, it is safer for you or your company to begin using an alternative internet browser such as Firefox. Firefox comes with a built-in pop-up blocker and spam blocker that are usually regarded as better than most off the shelf third party alternatives. So if you decide to go this route, you won't need add-on spyware or spam blocker protection. [http://www.mozilla.com/en-US/firefox/].

But if you decide to use an internet browser besides Internet Explorer or Firefox, it may not come with a strong pop-up and spam blocker. This means that you will need to download spam and spyware blocking software, Microsoft offers a free program entitled Windows Defender, which will alerts you if viruses, Trojan horses, or worms try to enter your computer and stop them. If you want protection beyond the off the shelf freebie version, you should consider acustomized security solution. [http://www.microsoft.com/athome/security/spyware/software/default.mspx]

By supplementing your firewall with the essential add-ons like a spam blocker, spyware blocker, and of course, an anti-virus program, you add valuable layers to your malware protection and better ensure that your computer remains malware free.

6. USE STRONG PASSWORDS
An effective firewall will shield out almost every attack by a hacker to gain access to your computer. No matter how effective a firewall, however, it can be rendered useless if a hacker is able to gain access to your sensitive data through direct means. For example, anyone can access your wireless network if they have the correct WEP encryption key. Similarly, a hacker need not breach your firewall to gain your banking information, if he or she can instead just guess your password. For these reasons, an essential part of supporting the effectiveness of your firewall is to use strong passwords.

Using a strong password requires four things:

  1. Length: One of the simplest methods that hackers use to obtain sensitive information is to simply start guessing. The longer a password the more letter and number combinations a hacker will have to try before he or she can guess a password. Even with a computer program designed specifically for trying every letter and number combination, most hackers are quickly frustrated by longer passwords.
  1. Structure: Hackers often use a password stealing method in which a computer program repeatedly tries various combinations of words out of a dictionary to guess a password. Consequently, your password should never be a single word found in a dictionary, nor should it be a combination of two or three words. Instead, your password should always involve either fake words or word and number combinations.
  1. Distinctness: Around the house, no one uses just one key to open the garage, backdoor, front door, the car, and their safe. Just as in the physical world, you should never use the same password for all of your access codes. If a single password holds the key to all your bank accounts, social security number, personal emails, and work intranet, then a single correct guess by a hacker will leave you and your company irreparably harmed.
  1. Frequency: Nobody is perfect, and you should build that assumption in when you consider how often you need to change your password. Eventually your password information will leak out to someone. But as long as you change your password frequently enough, you can minimize the chance that when the information leaks out, it will still be relevant. The frequency with which you change your password will depend upon how important the information it protects is, but under no circumstances should you give your personal password(s) to anyone.
7. A 128-BIT WEP ENCRYPTION ON YOUR WIRELESS NETWORK
No one would consider leaving a box of keys to the office laying right out side the office doors. Yet many individuals and small companies do just that when they fail to encrypt or password protect their office's wireless network. With an unencrypted network, anybody can access your network and thus access your company's computers. Even beginner hackers can then use this access to steal company information like credit card numbers and passwords, or barrage your computer with viruses and worms since they have essentially circumvented your network firewall.

While big companies need to undertake major steps to protect their wireless networks, for homes and smaller companies, WEP encryption is an easy and good solution. The most common WEP encryption is a 128-bit encryption, however, encryptions can range anywhere from 40-bit to 152-bit. Practically speaking, the higher the number encryption, the longer the password required to access your wireless network, and thus the harder to hack into. But if you are worried about performance and speed, there is very little difference in security between a 64-bit and a 128-bit encryption, and a 64-bit encryption will require slightly less time to log in to.

Setting up a wifi encryption is very easy to do, and the technology to encrypt comes standard on almost every commercially available wireless router. If you have not purchased a wireless router, you should consider D-Link and Linksys, two cheap but reliable systems. If you already have a wifi system that is not yet encrypted, just check the website of the manufacturer for your particular models instructions. Once the WEP is in place, the network is sealed and only users with the correct WEP can use the network.
[http://www.dailywireless.com/wifi/]
[http://www.dlink.com/]
[http://www.linksys.com/]

8. STANDBY IS YOUR PC'S BEST FRIEND
A hacker can only get to your computer remotely if it is accessible to him or her. That is to say, a hacker cannot remotely place a Trojan hore onto a computer that is not connected to the Internet. Consequently, one of the easiest ways to reduce your vulnerability to hackers and thus supplement your firewall's efforts to keep your computer malware free, is to shut down or change over to standby mode whenever you are not actively using your computer.

Remember that no matter how strong you make a firewall or how frequently you update it, a firewall can never provide perfect protection against malware. But by shutting the computer down each night and setting the computer to standby mode when not in use, you can cut your potential exposure to malware like viruses and Trojan horses by more than half.

9. TEST #1: LOOKING FOR LEAKS
Having tweaked and strengthened your firewall by installing certain software and taking certain preventative steps, you should now feel reasonably secure that your computer's firewall and overall safety are reasonably strong. But the only way you will actually know if your firewall is working well is if you do not get infected with malware. Since that trial by fire method of testing can be so dangerous, however, a safe alternative is to undergo firewall leak testing. These firewall leak tests will actually try to bypass your personal firewall and in so doing actually test the firewall's software filtering, and outbound filtering capabilities. Because each firewall link test uses slightly different techniques to try to circumvent your firewall (just like different malware will use different techniques), it is helpful to run a variety of different leak tests in order to ensure that your firewall makes the grade. There are a number of free online versions of firewall leak tests, including Gkweb's Firewall Leak Tester and Gibson Research Corporation's LeakTest.
[http://www.firewallleaktester.com/]
[http://www.grc.com/lt/leaktest.htm]

10. TEST #2: CHECKING THE PORTS
A port is not just a word for the socket that you plug your mouse or keyboard into. Rather, a port also refers to a special number in a data packet that helps route data to and from a particular program running on your computer. Ports can either be open, closed, or filtered. When a port is open, a hacker will be able to use that opening to gain easy access to your computer. Consequently, it should always be a goal to keep as few ports open for as short of time as possible.

Therefore, when you install a new program and find that your firewall is conflicting with it, make sure to tweak your firewall correctly by selecting a 'program exception' rather than a 'port exception' to get the program working. A 'program exception' will open the port only as that particular program needs it opened to function, that way a port will not remain open unnecessarily. A 'port exception' by contrast, will leave the entire port in open status.

Because of the stated security benefits of having ports open only as your programs need then opened, it is important to know exactly which programs use which ports, so that you can make sure that no ports are accidentally left permanently open. Thankfully, there are a number of free port scanners available online that will tell you the status of your computer's ports. A few of the more well-reputed are:

Microsoft's Port Reporter Tool. [http://support.microsoft.com/default.aspx?scid=kb;en-us;837243]
Sygate's Online Scan. [http://scan.sygate.com/] An extended security check that also includes a stealth scan and a trojan scan.
Planet Security's Firewall-Check. [http://www.planet-security.net/index.php?xid=%F7%04T%BDP%92nD] A fast test that checks currently highly endangered ports.
AuditMyPC's complete port scanning. [http://www.auditmypc.com/firewall-test.asp] An in-depth test which will scan all 65,535 of your computer’s ports.

CONCLUSION
While no single resource can adequately cover everything you need to know about maintaining your firewall effectively, the ten points introduced in this article should serve as a basic primer of the deficiencies of many firewalls as well as cover a few of the ways to upgrade, tweak and supplement your personal or small businesses’ firewall in order to improve your computer's overall security.

And while no computer is absolutely secure, at least you will have the advantage of knowing that you are more secure after reading this article than you were before.
-Birdy

If your computer is infected, and you need to fix it




Hundreds of thousands of computers worldwide may have been infected by hackers in an online advertising scam and may lose their ability to connect to the Internet on July 1, 2013. 

However since that date has come and past, the FBI and Homeland Security has put together another Report and Warning stating that on or about the 1st of July 2013, hundreds of  thousands (and perhaps millions) of people could become infected with a new virus designed to delete the Operating System on Computers, both personal and business.  Windows and Linux are particularly vulnerable to this new threat.

It is highly advised for individuals who have either Windows or Linux OS on their computers to check them here:   http://www.dcwg.org

Then, click on "Detect" in the upper left corner, or on the Green Button next to it.  At this point you will be directed to a new page. Pick your language from the list and click on the link next to it.

If your computer is not infected, you will see a green logo with the message: "DNS Resolution (equals) Green.”  Your computer appears to be looking up IP addresses correctly!"

If you see that message, you don't need to do anything more. You are safe.

If you see a message with a Red Logo saying your computer appears to be infected, you will be directed to a new page. You will be directed to websites that will provide antivirus tools that cyber-security experts have identified as being effective in removing the malware.  And they will provide you with further information on the case and the malware.

Please be Safe.
-Birdy

Wednesday, August 24, 2011

IS YOUR COMPUTER UNDER THREAT?



The language used to describe the types of threats that your computer may be vulnerable to can often get confusing. Here's a quick list of the types of threats that you'll find.
Drive-by Downloads
A drive-by download is computer code that takes advantage of a software bug in a Web browser to make it do something that the attacker wants—such as run malicious code, crash the browser, or read data from the computer. Software bugs that are open to browser attacks are also known as vulnerabilities.
Phishing Attacks
A phishing attack occurs when an attacker displays Web pages or sends emails that claim to be from a trusted company. These pages or emails solicit sensitive information from an unwitting customer.
Spyware
Spyware is any software package that tracks and sends personally identifiable information or confidential information to third parties.
Viruses
Viruses are a type of malicious code, or malware, typically spread by other computers through email, downloads, and Web sites that are not safe.
Heuristically-Detected Virus
A heuristically-detected virus is found based on the malicious behaviors that it exhibits. These behaviors may include attempts to steal a person's sensitive information such as passwords or credit card numbers
Worms
A worm is another type of malicious code, or malware, that focuses primarily on spreading to other vulnerable computer systems. It typically spreads by sending out copies of itself to other computers, either via email, instant messages, or some other service.
Unsolicited Browser Changes
An unsolicited browser change occurs when a Web site or program changes the behavior or settings of the Web browser without the user's consent. This may result in the home page or search page changing to another Web site, often one that is designed to serve ads or other unwanted content to the user.
Suspicious Browser Changes
A suspicious browser change occurs when a Web site attempts to modify the list of trusted Web sites. A Web site may be trying to get your Web browser to automatically download and install suspicious applications without your consent.
Dialers
A dialer is any software package that changes modem settings in order to dial a high cost toll number, or requests payment for access to particular content. The result of this attack is that the owner of the phone line is charged for services were never authorized.
Trackware
Trackware is any software package that tracks system activity, gathers system information, or tracks customer habits and relays this information to third-party organizations. The information gathered by such programs is neither personally identifiable nor confidential.
Hacking Tools
Hacking tools are programs used by a hacker or unauthorized user to attack, gain unwelcome access to, or perform identification or fingerprinting of your PC. Some hacking tools are used by system or network administrators for legitimate purposes, but the power they provide can also be misused by unauthorized users.
Joke Programs
A joke program is one that alters or interrupts the normal behavior of your computer, creating a general distraction or nuisance. Joke programs are programmed to perform various actions like causing the CD or DVD drive of your PC to open at random.
Security Risk
A security risk is a condition in which a computer is more vulnerable to an attack. This condition can be created when an otherwise innocent program contains an error that reduces the security of your computer. These errors are usually unintentional. Using such a program could increase the risk that your PC will be attacked.
Suspicious Application
A suspicious application is one with behavior that represents a potential risk to a computer. The behavior of such a program has been examined and determined to be unwanted and malicious.
Cybersquatting
Cybersquatting is the practice of acquiring a site name to attempt to deceive people about the identity of the organization running the site. Cybersquatting makes use of deceptive practices to mimic trusted brands or otherwise confuse users. Typosquatting is one form of cybersquatting in which name spelling variants are used.
Hard to Uninstall
These programs are difficult to uninstall. When they are uninstalled, they may leave behind files along with registry keys that cause the files to be run even after uninstallation.
Computer threats
Items such as viruses and worms that load directly on your computer, with the potential to do harm to your computer.
Identity threats
Items such as spyware or keyloggers that attempt to steal personal information from your computer.
Ecommerce safety threats
Suspicious ecommerce activities, such as selling counterfeit goods.
Annoyance factors
Items that don't necessarily do harm, but are a nuisance, such as joke programs or a site that isn't what it seems.
Pay per Click site
This indicates a Web site that includes the brand name in the Web site name, but is not affiliated with the brand owner and contains mostly advertisements or links to pages containing advertisements.



Tuesday, June 14, 2011

List of HTTP Status Codes



Status codes
301 Moved permanently
302 Found
303 See Other
403 Forbidden
404 Not Found


The following is a list of HyperText Transfer Protocol (HTTP) response status codes. This includes codes from IETF Internet standards as well as unstandardised RFCs, other specifications and some additional commonly used codes. The first digit of the status code specifies one of five classes of response; the bare minimum for an HTTP client is that it recognizes these five classes. Microsoft IIS may use additional decimal sub-codes to provide more specific information,[1] but these are not listed here. The phrases used are the standard examples, but any human-readable alternative can be provided. Unless otherwise stated, the status code is part of the HTTP/1.1 standard.

CONTENTS:
      * 1 1xx Informational
      * 2 2xx Success
      * 3 3xx Redirection
      * 4 4xx Client Error
      * 5 5xx Server Error
      * 6 See also
      * 7 References

1xx Informational
Request received, continuing process.[2]

This class of status code indicates a provisional response, consisting only of the Status-Line and optional headers, and is terminated by an empty line. Since HTTP/1.0 did not define any 1xx status codes, servers must not send a 1xx response to an HTTP/1.0 client except under experimental conditions.

100 Continue
This means that the server has received the request headers, and that the client should proceed to send the request body (in the case of a request for which a body needs to be sent; for example, a POST request). If the request body is large, sending it to a server when a request has already been rejected based upon inappropriate headers is inefficient. To have a server check if the request could be accepted based on the request's headers alone, a client must send Expect: 100-continue as a header in its initial request[2] and check if a 100 Continue status code is received in response before continuing (or receive 417 Expectation Failed and not continue).[2]

101 Switching Protocols
This means the requester has asked the server to switch protocols and the server is acknowledging that it will do so.[2]

102 Processing (WebDAV) (RFC 2518)
As a WebDAV request may contain many sub-requests involving file operations, it may take a long time to complete the request. This code indicates that the server has received and is processing the request, but no response is available yet.[3] This prevents the client from timing out and assuming the request was lost.


2xx Success
This class of status codes indicates the action requested by the client was received, understood, accepted and processed successfully.

200 OK
Standard response for successful HTTP requests. The actual response will depend on the request method used. In a GET request, the response will contain an entity corresponding to the requested resource. In a POST request the response will contain an entity describing or containing the result of the action.[2]

201 Created
The request has been fulfilled and resulted in a new resource being created.[2]

202 Accepted
The request has been accepted for processing, but the processing has not been completed. The request might or might not eventually be acted upon, as it might be disallowed when processing actually takes place.[2]

203 Non-Authoritative Information (since HTTP/1.1)
The server successfully processed the request, but is returning information that may be from another source.[2]

204 No Content
The server successfully processed the request, but is not returning any content.[2]

205 Reset Content
The server successfully processed the request, but is not returning any content. Unlike a 204 response, this response requires that the requester reset the document view.[2]

206 Partial Content
The server is delivering only part of the resource due to a range header sent by the client. The range header is used by tools like Wget to enable resuming of interrupted downloads, or split a download into multiple simultaneous streams.[2]

207 Multi-Status (WebDAV) (RFC 4918)
The message body that follows is an XML message and can contain a number of separate response codes, depending on how many sub-requests were made.[4]

3xx Redirection
The client must take additional action to complete the request.[2]

This class of status code indicates that further action needs to be taken by the user agent in order to fulfil the request. The user agent without interaction with the user may carry out the action required, if and only if, the method used in the second request is GET or HEAD. A user agent should not automatically redirect a request more than five times, since such redirections usually indicate an infinite loop.

300 Multiple Choices
Indicates multiple options for the resource that the client may follow. It, for instance, could be used to present different forma t options for video, list files with different extensions, or word sense disambiguation.[2]

301 Moved Permanently
This and all future requests should be directed to the given URI.[2]

302 Found
This is the most popular redirect code [citation needed], but also an example of industrial practice contradicting the standard.[2] HTTP/1.0 specification (RFC 1945) required the client to perform a temporary redirect (the original describing phrase was "Moved Temporarily"),[5] but popular browsers implemented 302 with the functionality of a 303 See Other. Therefore, HTTP/1.1 added status codes 303 and 307 to distinguish between the two behaviors. However, the majority of Web applications and frameworks still use the 302-status code as if it were the 303[6].

303 See Other (since HTTP/1.1)
The response to the request can be found under another URI using a GET method. When received in response to a PUT, it should be assumed that the server has received the data and the redirect should be issued with a separate GET message.[2]

304 Not Modified
Indicates the resource has not been modified since last requested.[2] Typically, the HTTP client provides a header like the If-Modified-Since header to provide a time against which to compare. Utilizing this saves bandwidth and reprocessing on both the server and client, as only the header data must be sent and received in comparison to the entirety of the page being re-processed by the server, then sent again using more bandwidth of the server and client.

305 Use Proxy (since HTTP/1.1)
Many HTTP clients (such as Mozilla[7] and Internet Explorer) do not correctly handle responses with this status code, primarily for security reasons.[2]

306 Switch Proxy
No longer used.[2]

307 Temporary Redirect (since HTTP/1.1)
In this occasion, the request should be repeated with another URI, but future requests can still use the original URI.[2] In contrast to 303, the request method should not be changed when reissuing the original request. For instance, a POST request must be repeated using another POST request.

4xx Client Error
The 4xx class of status code is intended for cases in which the client seems to have erred. Except when responding to a HEAD request, the server should include an entity containing an explanation of the error situation, and whether it is a temporary or permanent condition. These status codes are applicable to any request method. User agents should display any included entity to the user. These are typically the most common error codes encountered while online.

400 Bad Request
The request cannot be fulfilled due to bad syntax.[2]

401 Unauthorized
Similar to 403 Forbidden, but specifically for use when authentication is possible but has failed or not yet been provided.[2] The response must include a WWW-Authenticate header field containing a challenge applicable to the requested resource. See Basic access authentication and Digest access authentication.

402 Payment Required
Reserved for future use.[2] The original intention was that this code might be used as part of some form of digital cash or micropayment scheme, but that has not happened, and this code is not usually used. As an example of its use, however, Apple's MobileMe service generates a 402 error ("httpStatusCode:402" in the Mac OS X Console log) if the MobileMe account is delinquent.

403 Forbidden
The request was a legal request, but the server is refusing to respond to it.[2] Unlike a 401 Unauthorized response, authenticating will make no difference.[2]

404 Not Found
The requested resource could not be found but may be available again in the future.[2] Subsequent requests by the client are permissible.

405 Method Not Allowed
A request was made of a resource using a request method not supported by that resource;[2] for example, using GET on a form which requires data to be presented via POST, or using PUT on a read-only resource.

406 Not Acceptable
The requested resource is only capable of generating content not acceptable according to the Accept headers sent in the request.[2]

407 Proxy Authentication Required[2]

408 Request Timeout
The server timed out waiting for the request.[2] According to W3 HTTP specifications: "The client did not produce a request within the time that the server was prepared to wait. The client MAY repeat the request without modifications at any later time."

409 Conflict
Indicates that the request could not be processed because of conflict in the request, such as an edit conflict.[2]

410 Gone
Indicates that the resource requested is no longer available and will not be available again.[2] This should be used when a resource has been intentionally removed; however, it is not necessary to return this code and a 404 Not Found can be issued instead. However, despite the most common status code for such a page being 404 Not Found, 410 Gone is still used by some servers, including Geocities. Upon receiving a 410-status code, the client should not request the resource again in the future. Clients such as search engines should remove the resource from their indices.

411 Length Required
The request did not specify the length of its content, which is required by the requested resource.[2]

412 Precondition Failed
The server does not meet one of the preconditions that the requester put on the request.[2]

413 Request Entity Too Large
The request is larger than the server is willing or able to process.[2]

414 Request-URI Too Long
The URI provided was too long for the server to process.[2]

415 Unsupported Media Type
The request entity has a media type which the server or resource does not support.[2] For example the client uploads an image as image/svg+xml, but the server requires that images use a different format.

416 Requested Range Not Satisfiable
The client has asked for a portion of the file, but the server cannot supply that portion.[2] For example, if the client asked for a part of the file that lies beyond the end of the file.

417 Expectation Failed
The server cannot meet the requirements of the Expect request-header field.[2]

418 I'm a teapot
This code was defined in 1998 as one of the traditional IETF April Fools' jokes, in RFC 2324, HyperText CoffeePot Control Protocol, and is not expected to be implemented by actual HTTP servers.

422 Unprocessable Entity (WebDAV) (RFC 4918)
The request was well-formed but was unable to be followed due to semantic errors.[4]

423 Locked (WebDAV) (RFC 4918)
The resource that is being accessed is locked[4]

424 Failed Dependency (WebDAV) (RFC 4918)
The request failed due to failure of a previous request (e.g. a PROPPATCH).[4]

425 Unordered Collection (RFC 3648)
Defined in drafts of "WebDAV Advanced Collections Protocol",[8] but not present in "Web Distributed Authoring and Versioning (WebDAV) Ordered Collections Protocol".[9]

426 Upgrade Required (RFC 2817)
The client should switch to a different protocol such as TLS/1.0.[10]

449 Retry With
A Microsoft extension. The request should be retried after performing the appropriate action.[11]

450 Blocked by Windows Parental Controls
A Microsoft extension. This error is given when Windows Parental Controls are turned on and are blocking access to the given WebPages.[12]

5xx Server Error
The server failed to fulfill an apparently valid request.[2]

Response status codes beginning with the digit "5" indicate cases in which the server is aware that it has encountered an error or is otherwise incapable of performing the request. Except when responding to a HEAD request, the server should include an entity containing an explanation of the error situation, and indicate whether it is a temporary or permanent condition. Likewise, user agents should display any included entity to the user. These response codes are applicable to any request method.

500 Internal Server Error
A generic error message, given when no more specific message is suitable.[2]

501 Not Implemented
The server either does not recognize the request method, or it lacks the ability to fulfill the request.[2]

502 Bad Gateway
The server was acting as a gateway or proxy and received an invalid response from the upstream server.[2]

503 Service Unavailable
The server is currently unavailable (because it is overloaded or down for maintenance).[2] Generally, this is a temporary state.

504 Gateway Timeout
The server was acting as a gateway or proxy and did not receive a timely response from the upstream server.[2]

505 HTTP Version Not Supported
The server does not support the HTTP protocol version used in the request.[2]

506 Variant Also Negotiates (RFC 2295)
Transparent content negotiation for the request results in a circular reference.[13]

507 Insufficient Storage (WebDAV) (RFC 4918)[4]

509 Bandwidth Limit Exceeded (Apache bw/limited extension)
This status code, while used by many servers, is not specified in any RFCs.

510 Not Extended (RFC 2774)
Further extensions to the request are required for the server to fulfill it.[14]

See also

* List of HTTP headers
* List of FTP server return codes
* Custom error page

References

  1. ^ "The HTTP status codes in IIS 7.0". Microsoft. July 14, 2009. http://support.microsoft.com/kb/943891/. Retrieved April 1, 2009.
  1. ^ a b c d e f g h i j k l m n o p q r s t u v w x y z aa ab ac ad ae af ag ah ai aj ak al am an ao ap aq ar as at Fielding, Roy T.; Gettys, James; Mogul, Jeffrey C.; Nielsen, Henrik Frystyk; Masinter, Larry; Leach, Paul J.; Berners-Lee, Tim (June 1999). Hypertext Transfer Protocol -- HTTP/1.1. IETF. RFC 2616. http://tools.ietf.org/html/rfc2616. Retrieved October 24, 2009.
  1. ^ Goland, Yaron; Whitehead, Jim; Faizi, Asad; Carter, Steve R.; Jensen, Del (February 1999). HTTP Extensions for Distributed Authoring -- WEBDAV. IETF. RFC 2518. http://tools.ietf.org/html/rfc2518. Retrieved October 24, 2009.
  1. ^ a b c d e Dusseault, Lisa, ed (June 2007). HTTP Extensions for Web Distributed Authoring and Versioning (WebDAV). IETF. RFC 4918. http://tools.ietf.org/html/rfc4918. Retrieved October 24, 2009.
  1. ^ Berners-Lee, Tim; Fielding, Roy T.; Nielsen, Henrik Frystyk (May 1996). Hypertext Transfer Protocol -- HTTP/1.0. IETF. RFC 1945. http://tools.ietf.org/html/rfc1945. Retrieved October 24, 2009.
  1. ^ "HTTP/1.1 Section 10 Status Code Definitions". W3C. http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html#sec10.3.3. Retrieved March 16, 2010.
  1. ^ "Mozilla Bugzilla Bug 187996: Strange behavior on 305 redirect". March 3, 2003. https://bugzilla.mozilla.org/show_bug.cgi?id=187996. Retrieved May 21, 2009.
  1. ^ Slein, Judy; Whitehead, Jim; Davis, Jim; Clemm, Geoffrey; Fay, Chuck; Crawford, Jason; Chihaya, Tyson (June 18, 1999). WebDAV Advanced Collections Protocol. IETF. I-D draft-ietf-webdav-collection-protocol-04. http://tools.ietf.org/html/draft-ietf-webdav-collection-protocol-04. Retrieved October 24, 2009.
  1. ^ Whitehead, Jim (December 2003). Reschke, Julian F.. ed. Web Distributed Authoring and Versioning (WebDAV) Ordered Collections Protocol. IETF. RFC 3648. http://tools.ietf.org/html/rfc3648. Retrieved October 24, 2009.
  1. ^ Khare, Rohit; Lawrence, Scott (May 2000). Upgrading to TLS Within HTTP/1.1. IETF. RFC 2817. http://tools.ietf.org/html/rfc2817. Retrieved October 24, 2009.
  1. ^ "2.2.6 449 Retry With Status Code". Microsoft. 2009. http://msdn.microsoft.com/en-us/library/dd891478(PROT.10).aspx. Retrieved October 26, 2009.
  1. ^ "Screenshot of error page" (bmp). http://zfhb6a.bay.livefilestore.com/y1pKZJpcqDcSF9uKwaTmx301Ilr7cbJGN94HXCoHvPGwuwAlt5DA4ln0Y-F1WE6ZUC3URdiJdRe4hILTo87jWx2Yg. Retrieved October 11, 2009.
  1. ^ Holtman, Koen; Mutz, Andrew H. (March 1998). Transparent Content Negotiation in HTTP. IETF. RFC 2295. http://tools.ietf.org/html/rfc2295. Retrieved October 24, 2009.

14. ^ Nielsen, Henrik Frystyk; Leach, Paul J.; Lawrence, Scott (February 2000). An HTTP C Extension Framework. IETF. RFC 2774. http://tools.ietf.org/html/rfc2774. Retrieved October 24, 2009.


Powered By Blogger

Labels

Abduction (2) Abuse (3) Advertisement (1) Agency By City (1) Agency Service Provided Beyond Survival Sexual Assault (1) Aggressive Driving (1) Alcohol (1) ALZHEIMER'S DISEASE (2) Anti-Fraud (2) Aspartame (1) Assault (1) Auto Theft Prevention (9) Better Life (1) Books (1) Bribery (1) Bullying (1) Burglary (30) Car Theft (8) Carjackng (2) Child Molestation (5) Child Sexual Abuse (1) Child Abuse (2) Child Kidnapping (3) Child Porn (1) Child Rape (3) Child Safety (18) Child Sexual Abuse (9) Child Violence (1) Classification of Crime (1) Club Drugs (1) College (1) Computer (4) Computer Criime (4) Computer Crime (8) Confessions (2) CONFESSIONS (7) Cons (2) Credit Card Scams (2) Crime (11) Crime Index (3) Crime Prevention Tips (14) Crime Tips (31) Criminal Activity (1) Criminal Behavior (3) Crimm (1) Cyber-Stalking (2) Dating Violence (1) Deviant Behavior (6) Domestic Violence (7) E-Scams And Warnings (1) Elder Abuse (9) Elder Scams (1) Empathy (1) Extortion (1) Eyeballing a Shopping Center (1) Facebook (9) Fakes (1) Family Security (1) Fat People (1) FBI (1) Federal Law (1) Financial (2) Fire (1) Fraud (9) FREE (4) Fun and Games (1) Global Crime on World Wide Net (1) Golden Rules (1) Government (1) Guilt (2) Hackers (1) Harassment (1) Help (2) Help Needed (1) Home Invasion (2) How to Prevent Rape (1) ID Theft (96) Info. (1) Intent (1) Internet Crime (6) Internet Fraud (1) Internet Fraud and Scams (7) Internet Predators (1) Internet Security (30) Jobs (1) Kidnapping (1) Larceny (2) Laughs (3) Law (1) Medician and Law (1) Megans Law (1) Mental Health (1) Mental Health Sexual (1) Misc. (11) Missing Cash (5) Missing Money (1) Moner Matters (1) Money Matters (1) Money Saving Tips (11) Motive (1) Murder (1) Note from Birdy (1) Older Adults (1) Opinion (1) Opinions about this article are Welcome. (1) Personal Note (2) Personal Security and Safety (12) Porn (1) Prevention (2) Price of Crime (1) Private Life (1) Protect Our Kids (1) Protect Yourself (1) Protection Order (1) Psychopath (1) Psychopathy (1) Psychosis (1) PTSD (2) Punishment (1) Quoted Text (1) Rape (66) Ravishment (4) Read Me (1) Recovery (1) Regret (1) Religious Rape (1) Remorse (1) Road Rage (1) Robbery (5) Safety (2) SCAM (19) Scams (62) Schemes (1) Secrets (2) Security Threats (1) Serial Killer (2) Serial Killer/Rapist (4) Serial Killers (2) Sexual Assault (16) Sexual Assault - Spanish Version (3) Sexual Assault against Females (5) Sexual Education (1) Sexual Harassment (1) Sexual Trauma. (4) Shame (1) Sociopath (2) Sociopathy (1) Spam (6) Spyware (1) SSN's (4) Stalking (1) State Law (1) Stress (1) Survival (2) Sympathy (1) Tax Evasion (1) Theft (13) this Eve (1) Tips (13) Tips on Prevention (14) Travel (5) Tricks (1) Twitter (1) Unemployment (1) Victim (1) Victim Rights (9) Victimization (1) Violence against Women (1) Violence. (3) vs. (1) Vulnerable Victims (1) What Not To Buy (2)